Your server is running PHP version 5.1.2 but WordPress 3.4.2 requires at least 5.2.4.